Error occurred during parsing XML input for AI0001

I’m getting "Error occurred during parsing XML input for AI0001” and not sure what I’m missing. curl -v -X POST "https://silvergate.azure-api.net/account/balance" -H "Authorization: eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJDYWNoZUtleSI6IkFRQUFBTkNNbmQ4QkZkRVJqSG9Bd0UvQ2wrc0JBQUFBN0NVc1ltRnNvMDJrdy9qVnVpU1pqd1FBQUFBQ0FBQUFBQUFEWmdBQXdBQUFBQkFBQUFCNk1WMHBkdzdmdng5NmhrU2pVdmZiQUFBQUFBU0FBQUNnQUFBQUVBQUFBQks4ajdyeFY1MDNxUUtwL2l3QU1RRklBQUFBZmJxem9iYW1uY0RFZUtZb2JrbVdLRUhycXBuYUVxN082T21UZmNPRVJEK2xpOHltZU5LbUNQV3d3MmFOMFMyQ3FMNHA4WmRQejBISm9ucndWbVZML3dZUHZuL3d1STQ2RkFBQUFBblhsQngxUTk3c05MbnR3S05xVEp6YXRpaS8iLCJuYmYiOjE1MDUyNTAzNTEsImV4cCI6MTUwNTI1MTI1MSwiaWF0IjoxNTA1MjUwMzUxLCJpc3MiOiJTaWx2ZXJnYXRlIEFwaSIsImF1ZCI6ImFwaS5zaWx2ZXJnYXRlLmNvbSJ9.56j3GDW8L0ZAhzm8umipJ67QnqTFjDCehfWurXonXg4" -H "Content-Type: application/json" -H "Ocp-Apim-Subscription-Key: 8832b9872ce84bd38754593a046edf3c" --data-ascii "{'AccountNumber':'1003700117','SequenceNumber':'local'}" Note: Unnecessary use of -X or --request, POST is already inferred. * Trying 13.64.245.217... * TCP_NODELAY set * Connected to silvergate.azure-api.net (13.64.245.217) port 443 (#0) * TLS 1.2 connection using TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384 * Server certificate: *.azure-api.net * Server certificate: Microsoft IT SSL SHA2 * Server certificate: Baltimore CyberTrust Root POST /account/balance HTTP/1.1 Host: silvergate.azure-api.net User-Agent: curl/7.54.0 Accept: */* Authorization: eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJDYWNoZUtleSI6IkFRQUFBTkNNbmQ4QkZkRVJqSG9Bd0UvQ2wrc0JBQUFBN0NVc1ltRnNvMDJrdy9qVnVpU1pqd1FBQUFBQ0FBQUFBQUFEWmdBQXdBQUFBQkFBQUFCNk1WMHBkdzdmdng5NmhrU2pVdmZiQUFBQUFBU0FBQUNnQUFBQUVBQUFBQks4ajdyeFY1MDNxUUtwL2l3QU1RRklBQUFBZmJxem9iYW1uY0RFZUtZb2JrbVdLRUhycXBuYUVxN082T21UZmNPRVJEK2xpOHltZU5LbUNQV3d3MmFOMFMyQ3FMNHA4WmRQejBISm9ucndWbVZML3dZUHZuL3d1STQ2RkFBQUFBblhsQngxUTk3c05MbnR3S05xVEp6YXRpaS8iLCJuYmYiOjE1MDUyNTAzNTEsImV4cCI6MTUwNTI1MTI1MSwiaWF0IjoxNTA1MjUwMzUxLCJpc3MiOiJTaWx2ZXJnYXRlIEFwaSIsImF1ZCI6ImFwaS5zaWx2ZXJnYXRlLmNvbSJ9.56j3GDW8L0ZAhzm8umipJ67QnqTFjDCehfWurXonXg4 Content-Type: application/json Ocp-Apim-Subscription-Key: 8832b9872ce84bd38754593a046edf3c Content-Length: 55 * upload completely sent off: 55 out of 55 bytes HTTP/1.1 400 Bad Request Cache-Control: no-cache Pragma: no-cache Content-Length: 208 Content-Type: application/json; charset=utf-8 Expires: -1 Request-Context: appId=cid-v1:b12548f7-bd28-41be-a4f8-94e4d428815e Set-Cookie: ARRAffinity=197b31ffacc8908a2fafdad26cd5a86605ae1ea81352bfc8353d391af7fc76b9;Path=/;HttpOnly;Domain=sgapi-dev.azurewebsites.net X-AspNet-Version: 4.0.30319 X-Powered-By: ASP.NET Date: Tue, 12 Sep 2017 21:16:55 GMT * Connection #0 to host silvergate.azure-api.net left intact {"SEQUENCE":null,"ResponseData":null,"ERROR":[{"MESSAGEID":"AL99999","MESSAGETYPE":"E","SEGMENTID":null,"SEGMENT_OCCUR":null,"FIELDNAME":null,"ERRORMSG":"Error occurred during parsing XML input for AI0001"}]}

Comments

  •  
    Hello, this issue is most often cause by a parsing error when a quotation mark is missed or a data format is not adhered to. Right now, the SWAGGER or other API documentation will make it look like all arguments are in string format, but in actuality each argument has an underlying data structure. We are working to have this reflected in the generated API schema, but can answer specific questions that you might have.
    Posted by Hidden Tue, 19 Sep 2017 20:35:43 GMT
  •  
    thx.
    Posted by Hidden Tue, 19 Sep 2017 20:39:23 GMT


You're not signed in. Please sign-in to report an issue or post a comment.